
 

 

 

 

 

 

 
  

Unit 2  

Creating and Modifying Images 
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Lesson 1 

Introduction to the Basics of 

Creating and Modifying Images 
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Objectives 

Specific objectives (behavioral) by the end of this lesson the student will 

be able to: 

 recognize program of creating and modifying images (Gimp) 

 use the Help menu to identify the contents of the creating and 

modifying images program interface. 

 use some of the selection tools efficiently 
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The programs of creating and modifying images used to assist in designing, 

creating and modifying different images. It enables the user to modify photos 

or drawings. There are many of those programs which are a closed and open 

source programs. 

 

 

 

 Searching for some programs of creating and modifying images 

 By the help of your teacher, surf the Internet to search for some programs 

of creating and modifying images 

 

 

 There are various programs to create and modify images 

such as: 
 

 

 

 

 

 

 

 

Activity (1) 

 
 
 

creating and modifying images Programs 
 

  ِAdobe Photoshop 
Closed source 

GIMP 
Open source. 
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The GIMP program is an open and free source that allows creating and 

processing images. 

 

 

program GIMPoad L 

By the help of your teacher, download GIMP program. 

The Interface of the GIMP program is available in two forms. 

- Multi-window mode. 

- Single-window mode 
- 

The interface of the GIMP Program "A multi-window mode”" 

Important Note: 
When opening the GIMP program for the first time,  
it is usually on (the multi-window mode). 

Loading the GIMP program to create and modify images 

Activity (2) 
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- To facsilite the using the program, It could be in the (Single window mode from 

the Windows menu: → Single-Window Mode 
 

 

The program interface is shown in the mode (single window mode) as shown in 

the following figure: 

 

 
 

 

Note: 

After closing the program and reopening it, 

 it remains in the (Single-Window Mode) 
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"The interface of GIMP PROGRAM" 

" Single-Window Mode" and opening  one of its images . 

The GIMP program default Interface consists of : 

1.The Main Toolbox: 

The "tool box" consists of many tools such as the selection tools, back and front 

color tools.... 

2 .The Tool options dock:" 

It appears below the tool box and the options of the current tool (the selected) is 

shown in it. 

 

Identifying the contents of the GIMP program interface  
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3. "Image windows: 

when opening more than one image, each image appears in a window which you  

can navigate between them. 

4 .(The Layers/Channels/paths/Undo) dock:It contains several classifications, such 

as the Layers tab. 

5 .(Brushes/Patterns/Gradients) dock: It contains the clssification of Brushes, Forms 

tab, Gradients color schemes tab. 

 

 

 

To learn more about the program interface ..  

By the help of your teacher, 

Open the program, to know more about the GIMP program do the following: 

1-  Move the mouse pointer on the tool required to be known and wait for 

moments, the tooltip related to it is shown as well as its shortcut key . 

2-  To know more about the tool select the tool, click F1 from the keyboard to 

open the Help of this program. (bearing in mind to have your computer 

connected to the Internet). 

 
 

 

 

 

 

The Main Toolbox is considered the program main window contents which consists 

of many tools such as the selection tools .Through the Help which appears by 

clicking F1 from the keyboard you can identify the different contents of the program 

interface as well as get more information. 

 

 

 

Activity (3) (enrichment) 

 
 
 

Using the F1 "help" to identify the contents of the Program 

Interface (enrichment) 



 

 

Ministry of Education 

 

Computer, Information and Communication Technology 

 
86 

 

 

 

 

 

 

By the help of your teacher, open the GIMP do the 

following: 

1-  Click on one of the tools like "Rectangle" 

2-  Read the note about it . 

3-  Click on F1 to show the program Help. 

4-  Identify some of the selection tools through the 

program Help. 

 

 

Important notes: (enrichment) 

 

1- In the case of closing one of those boxes or tabs (tool box, selction tools box,....) It 

can be restored through the Windows menus → Recently Closed Docks 

2- To add , close or move one of the tabs in the box, click on the top right corner to 

open a drop-down menu and choose the required one. 

For more information on the GIMPprogram to create and process imagesvisit the  link 

http://docs.gimp.org/2.8/en of the program 

  

"Rectangle" 

Activity (4) (enrichment) 

 
 
 

http://docs.gimp.org/2.8/en
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Selection Tools 
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The selection tools are used to select a part or more of the image to deal 

with, like delete, cut, copy, paste, change the color of the selected part in order 

not to change the whole image. 

There are many selection tools used to specify part of the image, each one of 

them has a specific way to use it. The selection tools are shown in The Main Toolbox 

you can also access it through the Tools menu  

From the Tools Menu select Selection Tools 

 

 

 

 

 

 

 

 

Selection Tools 
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Choose the selection tool "Rectangle" by clicking on the tools box.  

To select, click by pushing  the image in the selected place so a rectangule is drawn 

as shown in the image 
 

 

 

               Tool Box 

Select  the image with the Rectangle tool 

 
 

Select part of the image with the rectangle tool. 
 

 By the help of your teacher, open the file of the previous image from the 

folder "Images" and do the following: 

1- Use the selection tool "Rectangle" to select the part of the image. 

2- Move the cursor inside and outside the selection. observing the shape of the 

cursor. 

3- Click by pushing when the shape of the cursor is changed. 

4- Deduce the difference between the different shapes of the cursor . 

 

1-Rectangle selection Tool 

 

Activity (5) 
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Note: 

1- The cursor in the selection area that takes the shape of   where you can move the 

selection rectangle. 

2- the cursor outside the selection area that takes the shape of   by clicking and pushing 

the selection place is changed. 
 

. 
Deducing the aim of the selection. 

By the help of your teacher, do the following: 

1- in the previous example, after using the selection 

tool "Rectangle" and select the image do the following: 

- change the front color in of the tool box to Red  

- choose the "Pencil" tool. 

- try to draw the lines with the "Pencil" tool inside and  

outside the selection. 

- write down your notes.- 

Deduce the aim of using the "Rectangle" selection tools. 

Note: 
- draw red lines in the selected part only. 

- to finish the selection and exit: 

From the Select menu Select None or( from 

the keyboard, click the  

( Shift key + CTRL + A ). 

 

 

 

 

 

Activity 
(6) 

 
 
 

The 

Front 

Color 
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The Ellipse select tool is used to select the oval 

shape of the image 

 

 

 

 

 

 

 

Select the oval shaped part of the Image using the Ellipse selection tool. 

By the help of your teacher do the 

following steps: 

1- Open the image file from the "images" 

folder. 

2- Select the Ellipse selection tool. 

3- Select part of the image using the 

Ellipse selection tool. 

 

 

 

 

 

 

 

Activity (7) 

 
 
 

The image after Selection 

2- Ellipse Selection Tool  
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The Lasso Free Selection tool is used to select an irregular 

part of the image in a free way. 

 

 
 

 

 

 

Select a part of the Image using the Lasso tool 

 

By the help of your teacher, use a free 

selection tool to select a part of the image as 

shown in the image : 

1- Use the image of the previous activity. 

2- Select a part of the image using  Lasso free 

selection tool 

3- from the Edit menu choose Cut. 

 Write down your notes. 

 
 
Note: 
-  a selected part cut.  

-  to remove the selection, from the Select menu select None 

3- Lasso free selection Tool  

 

 

Activity 
(8) 

 
 
 

The image after Selection 
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The Magic wand tool or Fuzzy Selection tool is used to 

specify similar color schemes areas of the image. 

 

 

 

 

 

 

Specifying similar color schemes areas of  the image with the Fuzzy tool. 

By the help of your teacher do the following: 

1-  Open the image file from the folder "images" 

2-  Select the similar color schemes of the Image using the Fuzzy tool. 

 

 

 

 

 

Activity 
(9) 

 
 
 

The image after specifying using 

Fuzzy Selection 
The image before Selection 

 

4- Fuzzy Selection (Magic Wand) tool 



 

 

Ministry of Education 

 

Computer, Information and Communication Technology 

 
94 

 

 

 

The Smart Scissors selection tool is considered a useful 

tool when trying to specify an area specified or 

distinguished with a clear and strong color where the 

colors of the borders are changed in a clear manner 

To use this tool, click on the points by pushing the 

area with distinguished color from the rest of the other 

ones. 

 

 

Specifying part of the image tool using the smart Scissors 

By the help of your teacher ,do the following steps: 

1- Open the image file from the folder "images." 

2- Use the Smart Scissors to make points by clicking and pushing on the area of 

distinguished color from the rest (the borders of the flower) as shown in the 

following figure: 

 

 

 

 

 

 

 

 

 
 

 

5- Smart Scissors Selection tool 

Activity 
(10) 

 
 
 

The image while specifying it 
The image after completing specifying it. 
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Remember 
The GIMP program is an open and free source program that allows creating 

and processing images. 

When opening  the GIMP program for the first time it is usually on 

(the multi-window mode). 

- To facilite using the program, It could be in the (Single window mode from the 

Windows menu  → Single-Window Mode 

The GIMP program default Interface consists of : 

.1 The Main Toolbox . 

2 .The Tool options Dock.  

 .3 mage windows. 

4 . (The Layers/Channels/paths/Undo) Dock. 

5. (Brushes/Patterns/Gradients) Dock. 

To know more about the tool select it, click F1 from the keyboard to open the Help 

of this program 

- To restore any closed tabs: 

Windows menu → Recently Closed Docks 

 

- The selection tools are used to select a part or more of the image. use the 

selection tools to select one or more of the image, 

-  The selection tools ( Rectangle tool, Ellipse tool, Free Selection (Lasso), Magic 

Wand tool or Fuzzy Selection and Smart Scissors ) 
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Question1: Mark ( √ ) on  the right statement and  (x) on the wrong one: 

1- On opening the GIMP program for the first time ,the program is shown 

in the multi window-window mode     ( ).  

2- For more information about one of the tools ,click F5 from the 

keyboard           ( ). 

3- Use the "Selection" tool to draw the image freely   ( ). 

4- The "Pencil tool" is considered one of the selection tools ( ). 

5- The "Ellipse" selection tool is used to select an oval shape of the 

image.          ( ).  

Question2: Complete the following: 

1- To delete the selection, Choose ............................... 

2- The "Lasso" Free Selection tool is used to select ................. 

3- The "Magic wand" tool or "Fuzzy Selection" is used to select ........... 

4- The " smart Scissors " selection tool is used to select ..............  

 
 

Answer questions through: 

MS Word program in the file of "answers of the first lesson" in  

(The template of Answers and projects). 

 

Questions and Exercises 
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A question to prepare for the next lesson: 
 
After identifying some of the selection tools and how to use 

them, 

 How can you use the selection tools to create a new image? 
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Lesson 2 

Designing and Creating New Images
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Objectives 

Specific objectives (behavioral) by the end of this lesson, a student will be 

able to: 

* create a new image file. 

* design simple drawings. 

* save the image file and all its data using the option Save. 
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To create a new image file (New Image) from the File menu choose New, a 

dialogue box appears which requests the dimensions of the new image (length and 

width), its resolution, color scheme and its filling color 

To create a new image file    File menu          New 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1-Template: Templates are ready made designs previously 

prepared of the dimensions and the resolution of the 

picture. by clicking on the drop down list a template 

appears to select from instead of selecting manually. 

 

Create a new image file (File menu             new) 

2 

1 

3 

The dialogue box of creating a new image 
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2-  Image Size: To identify the dimensions of the new image (length and width) click 
on the arrows . 

3- Advanced Options :by clicking on + sign The rest of the dialogue box appears as 

follows: 
 
 
 
 

 
 
 

 
 

 
 
 
 

4- X resolution and Y resolution: This is used to determine the image resolution 

when printing (and it does not affect the picture dimension) 

5- Color Space: This is used to determine the Image color system RGB using red, 

green and blue colors or that of the grayscale using black and white colors and 

the gradients of grey between them. 

6- Fill with: issued to specify the new image filling color which can be: 

- Background Color which appears in the Toolbox. 

- Foreground Color which appears in the Toolbox. 

- White filling the image in white color. 

-Transparency the transparency of the image is to make the background of 

  the image transparent. 

 

 

 

The dialog box to create a new image 

 4 5 

6 
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Create a new image file using Template to specify the dimensions, background color 

and the filling color of the new image. 

 

 

 

By the help of your teacher, create a new image of 

 (600 X 800) and fill its background color. 

   

In the opposite figure the color of the background is shown in 

white. 

- to choose another color of the background click on the toolbox of 

Background Color in the dialogue box. 

- To open a dialogue box to change the background color "Change 

Background Color" do the following: 

1- click by pulling to change the current background color. 

2. Current: Is the color of the current background. 

3. Click "OK". 

- From the File Menu Choose New. 

A dialogue box of a new image appears to choose 

the following: 

- From Template Choose  600 X 800 

- From Fill with Choose Background Color. 

- Click "OK". 

- The new image is shown in this Figure. 

 
 
 
 
 

Activity 
(1) 
 
 

The color of the 

current 

background 

1 

The new image in the image window  
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By the help of your teacher use one of the selection tools to try implementing the 

next drawing: 

 

 

 

 

Steps of the activity 

-Create a new file from the File menu and select New, a dialogue box appears to 

select the dimensions of the new image. 

 

 

 

 

 

 

 

Choose the "lasso" free selection tool to draw the abbreviation "EG" as follows: 

1- To draw the first letter "E" ,click by pulling the free selection tool until the 

completion of drawing the letter. 

2- To draw the second Letter "G", it should be noted that when you click by pulling 

to draw it the first letter "E" disappears. 

3- To keep the previous specified selection of the "Lasso" free selection tool click on 

to "Add to current Select". 

4. Choose the color filling "Bucket Fill" Tool, click inside this selection to fill it with 

the front color. 
 

 

Activity 
(2) 

 
 
 

Specify the 

dimensions of the 

new image 

Design simple Drawings 
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By the help of your teacher, draw the following figure: 

To draw the figure ,you must try the following: 

- A careful look to the figure or image. 

- Try to guess the tools that will be used. 

- Identify the starting point. 

 

Note that: the figure is composed of a group of oval shapes,  

thus the tools Ellipase, Bucket Fill and Pencil Tools can be used. 

 

 

 

Activity 
(3) 

 
 
 

1- Specifying letter "E" 3-Add Letter "G" 

4 - Select the "Bucket" tool to fill the selection with color. 

Steps of the Activity 

2-Click on the icon 

"Add selection" 

from tool options 
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By using the Bucket Fill, the brush, Pencil Tools and the 

choice of the front color the drawing is completed. 

 

 

 

 

 

 

Add to the 

current  

Selection 

The deletion 

of the current 

selection 

Steps of the Activity 
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Draw an oval shape with green colored borders and fill it with a yellow color. 
 
 

1. Open a new file image from File menu    new. 

2. Select the Ellipse selection tool. 

3. Select the green as front color from the tool box. 

4. From the Edit menu choose Stroke Selection, a "Stroke Selection" dialog box 

appears  

5. Select the line width from "Line width" from the dialog box. Click on "Stroke", the 

borders of the oval shape are drawn with the green color 

6. Select the yellow as front color from the tool box. 

7. From the Edit menu select Fill with FG Color; the selection is filled with the front 

color with yellow. 

The following figure shows the implementation steps: 

 

 

 

 

 

 

 

 

  

Activity 
(4) 

 
 
 

Step(1) Step(2) 

 

Step(3) 

 

Step(4) 

 

Step(5) 

 

Step(6) 

 

Step(7) 
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By the help of your teacher try drawing the following: 
 

 

 

 

 

 

 

 

 

 

 

 

 

Using the following tools: 

-  Ellipse Select tool. 

-  Pencil Tool. 

 - The Lasso free selection tool. 

-  Bucket Fill Tool. 

 

 
 

After finishing the drawing the image, the stage of saving it in the file comes. 

Save Image through the command Save from the File menu: 

The command Save is used from the File menu, since the GIMP program offers the 

extension XCF to the image file, to save all the information about the image (Layers. 

Transparency) This extension is useful in case of reopening the file of the image or 

modifying it. 

Activity 
(5) 

 
 
 

Save Image 
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Remember 

create a new image file through: File  menu              New. 

In the dialogue box to create a new image: 

1-Templates: are previously ready-made designs prepared of the dimensions and 

the resolution of the image.  

2-Image Size :to identify the dimensions of the new image (length and width) by 

clicking on the arrows . 

3 -Advanced Options : to create the new image 

4-resolution : used to determine the image accuracy when printing  

5-Color Space:This is used to determine the Image color scheme RGB or  

grayscale  

6- Fill with: It is used to specify the new image filling color which can be: 

-Background Color 

- Foreground Color  

- White filling the image in white color. 

- Transparency to make the image background transparent. 

 

 

When save the image by the command Save from the File menu: 

The GIMP program offers the extension XCF to the image file, to save all the 

information about the image (Layers. Transparency. ).. 
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Complete the following statements: 

First: To create a new image, the following steps should be followed 

1. Identify the dimensions of the new image. 

2. .................................. . 

3. .................................. 

4. .................................. 

5. .................................. 

6.  ....................................  

Second:  

save command is used from the File menu, where the GIMP program offers     ..........  

Answer questions through: 

MS Word program in the file of "answers of the second lesson" in  

(The template of Answers and projects). 

Questions and exercises 
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A question to prepare for the next lesson: 

The drawing tools are used for different purposes like hand drawing 

and for gradation of colors. 

 

What are the drawing tools? How could they be used? 
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Lesson 3 

Paint tools
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Objectives  

Specific objectives (behavioral): By the end of this lesson, the 

student will be able to: 

 

 * draw a free shape. 

 * draw gradient color scheme. 

 * copy part of the picture in the same layer. 

 * repair the  defects of the image color scheme. 

 

 

 

 

 



 

 

Ministry of Education 

 

113 
First Year Prep  

 

 

 

 

Paint tools are used for different drawing purposes such as free hand drawing, 

create gradient color scheme, merge the current color with the surrounding colors, 

copy part of the picture in another place in the same image... 

The Paint Tools that can be accessed from the Tools Menu 

 

 

 

 

 

 

 

 Or from the Tools Box 

 

Paint Tools 

 

 

 

Paint Tools 

 

Paint Tools 
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t Tools 

The pen in the "Pencil"  tool is used for free hand drawing 

 

 

By the help of your teacher, identify the options tool of the 

"Pencil tool", to find out how to change the size and the 

shape of the brush as well as other uses. 

- choose the shape of the brush. 

- choose an appropriate brush size 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1-  Pencil Tool 

 

Activity 
(1) 

 
 
 

click (+) to 

show more 

about the 

brush 

To change 

the brush 

size  

Different forms of 

Brush by clicking 

on any of them 

they are selected  
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Drawing using the "Pencil" tool 

By the help of your teacher, draw the following figure 

 

1- choose  the "Pencil tool". 

2- Modify the options of the tool to change the size and 

shape of the brush. 

3- choose Foreground color "red". 

1-choose the front color from the tools box. 

2-select the shape and size of the brush used from the 

Tool Options of the pencil tool 

 

 

 

 

 

 

 

 

 

 

 

The drawing in the image window    

          Pencil tool options 

 

 

Activity (2) 

 
 
 

1 

2 
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The gradient color scheme Blend tool is used to 

make color gradation using the front or back colors. 

Modifications are made to the options of the tool to get 

the gradient color scheme required. 

 

 

By the help of your teacher, do the following: 

- create a new file. 

- choose the Blend tool. 

- choose the shape of the gradient color scheme. 

- select the direction of the gradient color scheme. 

-Create a gradient color scheme by clicking and pulling in the image window. 

 

 

 

 

 

 

 

 

 

 

 

 

2- Blend Tool 

 

Activity 
(3) 

 
 
 

By clicking and pulling to create 
the gradient color scheme 

The gradient color scheme 
after drawing 

The options of the gradient 
color scheme 
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The Smudge Tool is used to mix the current color with the 

surrounding colors in the area of moving the tool. 

 

 

By the help of your teacher, try to do the following: 

- Use the Picture of the previous activity. 

- Choose Smudge tool. 

- Choose the (shape and size of the brush) from the tools options. 

- by clicking and pulling the tool in the picture to mix the 

current color with the surrounding colors. 

 

 

 

 

 
 

 

 

 

 

 

 
 

The picture after using the smudge  

 

 

The Tool Options 

 

 

 

3- Smudge Tool 

 

Activity 
(4) 
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The Clone tool is used to copy part of the picture in another 

place (in the same image layer). It is used to modify and 

reform the images. 

The steps of using the Clone tool: 

- look at the picture to know the part required to be copied. 

- Choose the Clone tool. 

- stop the cursor at the beginning of the place required to be 

copied 

- press the "CTRL" key on the keyboard (the cursor shape changes to ) 

- move to the required place to add the copied version. 

- click by pulling to create the copied version. 

- do not stop clicking and pulling till you complete the copying. 

 

 

By the help of your teacher, use the "Clone" tool try to copy part of the picture as 

follows: 

 

     original image.                 The picture after copying using clone tool   

4- Clone Tool 

 

Activity 
(5) 

 
 
 



 

 

Ministry of Education 

 

119 
First Year Prep  

 

o 

 

Steps in implementing the Activity 

 

 

 
 

 

 

 

 

 

 

 

 

Steps of copying using the Clone tool 

Important notes 

- While copying click by pulling in the copying place till completing the required 

copied part. 

- By stopping to click by pulling with the cursor then re-clicking by pulling, copying 

occurs from the selected starting point. 

- To control the copying process change the size and shape of the brush used from 

the Clone tool options. 

 

 

1-Select the starting point of the 

copying by pressing the Ctrl key 

2- Move to the 

place of putting 

new copy 3- Press by pulling the 

copied version then 
continue pressing till you 
finalize the copied version 
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By the help of your teacher, try to do the following: 

- Check the picture 1 and picture 2 well to identify the differences between them. 

- Use a Clone tool to make picture 1 (original picture) look like picture 2. 

- Use the Smudge tool to mix and blend the color with the surrounding Colors 

 

picture 1 (the original image)       picture 2 the image after modification 

  
Steps in the implementation of the Activity 

 

 
 

  

 

 

 

 

 

 

 

 

 

 

 

 

Activity 
(6) 

 
 
 

1-Select the Clone tool, select 
the starting copying area then 
press CTRL 
 
 

2-click by pulling using the 
Clone tool. 
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4-Move the rest of the image by 
clicking on the space bar + the 
cursor. 

-3 magnify the  image using the 
Zoom tool to best see the details 

5- Modify the  difference in the color 
scheme by using the Smudge tool to mix 
and blend the current color with the rest 

of the colors. 

6- Final shape of the image. 
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By the help of your teacher, Identify the usage of some of the drawing 

tools of the Paint tools such as: 

Paintbrush - Eraser          - Ink    

Use the Ink   tool  like a fountain pen to control drawing distinguished 

borders and edges with the brush 

Use the Eraser       tool to remove a coloring Space of a picture or a drawing. 

Use the Paintbrush tool  to draw clearly 

  

Activity 
(7) 
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Remember 

 

Paint tools are used for different drawing purposes, such as free hand drawing, 

gradient color scheme creating, the current color with the surrounding colors 

merging, to copy part of the picture in another place in the same picture ... 

 

Paint tools: 

The pen in the Pencil  tool used for free hand drawing 

The Gradient color scheme Blend tool used to make color gradation using the 

front or back color 

The Smudge tool used to mix the current color with the surrounding colors  

The Clone tool used to copy a part of the picture in another place (in the same 

image layer). 
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Question One :: Mark () by the correct answer and a (x) by the wrong one: 

1. Use the Pencil tool to make a free hand selection. ( ) 

2.The Clone tool used to mix the current color with the surrounding colors in the 

space where the tool is moving.    ( ) 

3. One of the selection tools is the Blend tool.  ( ) 

4. The Smudge tool is used to copy part of the image in another place in the 

same image layer, it is well known for modifying and reforming images. ( ) 

5. The Eraser tool is used to delete a color space of a picture or an image.( ) 

Question 2: Rearrange the following steps of using the Clone tool: 

) (stop the cursor at the beginning of the place required to be copied  

) (look at the picture to know the part required to be copied. 

) (move to the required place to add the copied version. 

) (do not stop pressing and pulling till you complete the copying. 

) (choose the Clone tool. 

) (press the "CTRL" key on the keyboard (the cursor shape changes to   ) 

) ( click by pulling to create the copied version. 

 
Answer questions through: 

MS Word program in the file of "answers of the third lesson" in  

(The template of Answers and projects). 

Questions and exercises 

 

 

 



 

 

Ministry of Education 

 

125 
First Year Prep  

 

 

 

 

 

 

 

 
 
 
 
 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A question to prepare for the next lesson: 
 
Sometimes we need to rotate or flip an image 
 
What are the tools that help doing this? How can they 
be used? 
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Lesson 4 

Transforming and Resizing Tools 
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Objectives 

Specific objectives (behavioral) :By the end of this lesson the 
student will be able to: 

 * move the image. 

 * cut the image. 

 * rotate an image. 

 * add reflection to the image. 

 * resize the image 
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Transform tools are the tools used to change the image format either by 
transforming, resizing, changing the image dimensions .to access the tools of the 
Transform tools go to the tools menu, or through the square tools .There are 
more than one tool and each one has a function and a method of use. 
 

 
 

 
The Move tool is used for moving the image 
or the layers of an image to frame or text. 

 

 

By the help of your teacher, identify how to use the Move tool, use the image of the 
previous activity, by clicking and pulling the Move tool the image is moved. 

 

 

 

 

 

 

 

 

Transforming tools 

 

1- Move tool 

 

 تدريب

 
 
 

Activity 
(1) 

 
 
 

The Image after using the Move tool The original Image 
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With the help of your teacher use the Move tool 

 - Open the image file from the image folder, using one of selection tools, 
select the image. 
- To move the selection, continue pressing ALT + CTRL till you move the 
selection. 

  
 

 

 

 

 

 

 

  
 

  

 

Crop tool is used to cut a part of the image.     

 

 

 

 

2- Crop Tool 

 

Activity 
(2) 
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With the help of your teacher, crop an image using Crop Tool. 
- Open an image file. 
- Select Crop 
 -Drag and drop the image to select the needed part. 
- Press Enter from the key board. 
 
 
 
 
 
 

    original Image    select the part needed      image after crop    

  

 

Rotate tool used to rotate an image 
   
-With the help of your teacher, rotate an image using Rotate Tool 

- Open an image file. 
- Select Rotate. 
- Drag and drop to rotate the image. 
- Press Enter from the keyboard after finishing. 

 
 

 

3- Rotate Tool 

 

Activity 
(3) 
 
 
 
 

 
 
 

Activity (4) 
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Steps of the activity 

 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2- Select Rotate to show dialgo 
box of rotate angle 

 

1- The original image 

 

3- Press and drag to rotate the image 4- Press Enter to finish Rotate. 
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Flip Tool is used to flip horizontally or vertically 
an image.  

 

With the help of your teacher, flip an image. 
- Open an image file. 
- to make horizontal or vertical flip, select Flip tool 

then from Tool Options dialogue box, select an option. 
  
 

 

 

 

 

 

 

 

 

 

 

 

 
 

4- Flip Tool 

 

Activity 
(5) 

 
 
 

Tool Options 

 

Original image 

 

Vertical Flip  

Horizontal Flip 
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Scale Tool is used to change the dimensions of an 
image [length and width.] 

 

 

 

 

 

 

With the help of your teacher, change the dimensions of an image . 

- Open an image file. 

- Select Scale Tool. 

- Press on an image to show the dialog box to decide the dimensions and image 

corners. 

- Drag and pull to change the dimensions of the image through the dialog box. 

- Press Enter from the keyboard when you finish. 

 

 

 

 

5- Scale Tool 

 

Activity 
(6) 

 
 
 

Original image 

 

Image after changing dimensions 
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  1-Original image 

 

point to drag 

2- Select Scale to see this sign. 
 

The pointer 

after 

selecting 

Scale 

3- Presss and drag to 
one point to change the 
dimensions or from the 
dialog box. 

4-Move the dialog box 
to see the dimensions. 

 

5- Select Scale from the dialog box  

 

 

6-Image after changing 
dimensions. 
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Note: 
You can use Crop tool after changing the dimensions. 
 

 

 

 

Remember 

Transform tools is used to change the shape of an image by moving 
or resize. The Transform tools can be used from the Tools menu, or from 
the dialogue box. There are different tools, each of which has a function 
and usage. 

Transform tools: 

- Move tool which is used to move an image or image layers or selection or 

text. 

- Open an image file from the Image folder, Use a selection tool to select a part 

of the mage. 

-To move a selection, press ALT + CTRL, continue pressing using the Move tool 

to move the selection. 

-Crop tool is used to crop part of an image. 

-Rotate tool is used to rotate an image. 

-Flip Tool is used to horizontally or vertically flip an image. 

-Scale tool is used to change the dimensions of an image. 

 

Image after changing dimensions  
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Question 1-Tick () or ( X) 
1- Transform Tools are used to change the form of an image through 

move, resize or change dimensions.              ( ) 

2-Move Tool is used to move an image or image layers or selection or text.      ( ) 

3- To move, press Alt + CTRL and continue pressing using the Move tool.        ( )  

4- Rotate tool is used to crop an image.              ( ) 

5- Crop tool is used to rotate an image.                   ( ) 

6- Scale tool is used to make horizontal or vertical flip of an image.         ( )  

7- Flip tool is used to make change an image dimensions [length, width]. ( )  

Question 2: Put the following steps in the correct order to use Scale tool: 

(    ) open an image file. 

( ) Drag and pull at one corner to change the dimensions or from the dialog 

box. 

( ) Press the tool on the image to show the dialog box to decide the image 

dimensions. 

( ) Press Enter from the keyboard after finishing the dimensions. 

( ) Select the Scale Tool. 

 
Answer S Word from the answer file in Mthrough Answer is done ( 

)Template and Projects 
 

Exercises 
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Lesson 5 

Image layers
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Objectives 

 

Specific objectives (procedural) :By the end of this lesson, the 

student will be able to 

• recognize the concept of image layers. 

• be proficient in the use of the image layers to create an image. 

• modify an image using image layers. 

• insert text over the image. 

• export image file with an appropriate extension. 
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There is "Layers" tab within tabs box (layers, channels, paths, undo), 
and uses the "Layers" tab to edit, add and control different picture layers, and 
can think of the image layers as slices are placed on top of each. Layers are 
used to assist in the development of the 
components and the details of different pictures so 
that every part or detail of the image in the layer 
mode, can address this part of the picture 
(scanning - rotation - identification ...) without 
affecting the rest of the image parts, representing 
the bottom layer (lower layer) background image 
"background" and come above the rest of the layers 
to contain the rest of the image details. 

 
 

Image consisting of several layers is represented as follows: 
 

 

         

                                          
 

                                               

Image Layers 

 

" The Layers, Channels, Paths, Undo 
History dock " 

The image in its final 
form 

The   Image layers 
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You can get to the "Layers" tab through: 
- The main interface of the program. Or 
- Through   Windows menu → Dockable Dialogs → Layers 

 

 
 

 

 

 

 

 

 

 

 

 

1- Layer visibility -    to make the layer visible or invisible. 
2- Layer thumbnail -is a mini format of the layer and the layer name 

appears next to it (and can be changed by clicking on it). 
3- New layer -to add a new layer 

Dealing with the Layers 

 

1 2 

3 4 

5 

6 7 

The image in the images window  

Tab  " Layers" 
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4- Raise layer   -to move the layer to the highest level. 
5- Lower layer-   to move the layer to a lower level. 
6- Duplicate layer -   to copy the current layer. 
7- Delete layer   -to delete the current layer. 

  
 

With the help of your teacher, add a new layer: 
- To add a new layer, click on the New layer in the "Layers" tab. 
- To show the dialog "New Layer." 
- Press OK, a new layer is added  

        
  
 

 

 

 

 

 
 

  

New layer is 

transparent 

Activity 
(1)  

 
 
 

Foreground 
color for new 

layer 

Background 
color for new 

layer 

No Fill (Transparency) 

Dialogue box for a new layer  
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Note: 
to deal with the layer, it must be pressed to become the current active Layer. 

 

With the help of a teacher, choose one layer, mark the layer invisible: 
- In the previous training, a layer is to chosen and pressed to become the 
current active layer. 

  
 

 

 

 

 

 

  - To make the image layer invisible, click on the 
Layer visibility icon, and then the layer disappears. 

 

 

 

 

 

Activity  
(2) 

 
 
 

A new 

transparent 

layer 

The layer is 

invisible  

The image in the images window  

Images window (the layer that has the image disappears). 
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 To reshow the layer content, click the layer visibility icon again. 

 

 

With the help of your teacher, rename the layer: 

To rename the layer, double click on the layer and give it a new name. 

      
 

 

 

 

 

Important Notes: 

-  To deal with the layer, you must make sure it is the current active layer by 
clicking on it. 

-  For ease of working with one of the layers, you can hide the rest of the 
layers by clicking on the layer visibility icon and dealing with the required 
layer icon. 

-  You can reorder layers using the arrows up and down in the Layers tab. 

  

Activity  
(3) 

 
 
 

A new 

name for 

the layer 
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With the help of your teacher, try to make a shadow for the following picture: 
Open the image file from the "Photos" folder; try to make a shadow for the image. 

 
 

 

 

 
 
 
 
 
 
 

Steps to implement the activity: 
1. Select the white color in the original image using Fuzzy tool; the 
white space around the flowers is selected. 
Important note: 

- There are some images which may not allow Cut or Delete a part from it. 

- To make the image liable to delete part of, do the following: 

-You must make sure that there is no selection in the image (Select-None). 

- Choose from the list of Layers Transparency and then choose Add Alpha 
Channel. 

- The Alpha Channel represents the transparency of the image. 

Activity 
(4)  
 
 

The image with a shadow 
Original image 
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2- Press "Delete" key from the keyboard, then selected white space around 
the flowers is cleared. 
3- Insert a new layer with name "Shadow." 

 
 

 
 

 
 

 

4- from the list Select, Choose Invert to invert the selection and determine 
the shape of flowers. 

5- Make sure that the new layer "Shadow" is the current layer. To change the 
foreground color in gray - Use the Bucket Fill tool to make color packing in 
gray inside flowers selection 

1 

2 3 



 

 

Ministry of Education 

 

Computer, Information and Communication Technology 

 
146 

 

 

 

 
 

 

6- Rearrange the layers so that the layer "Shadow" is the bottom layer 
7-to end the selection, from the Select menu, choose none. 
 

. 
 

 

 

    
 

8- Move the upper layer of the flowers 
using the Move tool to show the 
shadow. 

 
 

                                                               
 

4 5 

6 
7 

8 
The final image with shadow 
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Your text is inserted through the Text tool, and 
it should be noted that when using the text tool is 
automatically inserted a new layer for the text, and 
the text box be shown in which text will be written, 
new layer name will be words from the beginning of 
the written text. 

We are dealing with text written specifically to change the font color and 
font type of text tool options. 

To move the text layer text is selected to become the current layer, using 
the Move tool and stand on the text and press and drag him are moving it. 

Adjustable in the text must select the text layer to become the current 
layer, and then select the text inside the text box and the amendment to it. 

 
 

 
                    With the help of your teacher, 

type the text "the beautiful flowers" in the form 
of flowers in the former activity and export 
the image file with appropriate extension 

  
 

 

Text tool (enrichment) 

 

Activity 
(5)  
 

The beautiful flowers 
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Steps to implement the activity  
 

 

 

 

 

 

  

When choosing the text tool, the text box appears 
in which the text can be written and edited. 

 

A new layer is automatically inserted 

Text tool options 

To get Out of the write mode, 
press on any other layer 

The beautiful flowers 
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You can get more information about the text tool from the link: 

http://docs.gimp.org/2.8/en/gimp-tool-text.html  

  

 

 

 

To export the image as a file with a suitable extension (JPG, ... GIF), 

follow these steps: 

- Ensure that all layers are Visible. 

- integrate all layers, and to merge the layers into a single layer 
choose Flatten Image of the Image menu.  

- From the File menu choose Export, 
select the appropriate extension of the file 
and its name. 

 

 

 

 

 

 

Export image to a file with an appropriate extension  

http://docs.gimp.org/2.8/en/gimp-tool-text.html
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 Remember  

- the "Layers" tab uses to edit, add and control different picture layers. 

- To make the layer invisible, press on the icon.  
- To add a new layer, press on the icon . 
- To move the level of layer to the top, press on the icon.  
- To move the layer to a lower level, press the icon . 
- To copy the current layer,  press on the icon.  
- To delete the current layer, press on the icon.  

 
- To deal with the layer, press on it so that  the current layer becomes "Active 
Layer." 
- To rename a layer, Double Click on the layer and type its name. 
- When you insert the text, a new layer is inserted and the layer is named 

automatically with words from the beginning of the written text. 
 

 
To export the image as a file with appropriate extension: 
- ensure that all layers are Visible. 
- merging all layers, to become one layer, choose Flatten Image 
from the Image menu 
- from the File menu,choose Export, select the appropriate 
extension of the file and type the file name. 
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First question:  

Complete the following phrases: 
The following picture shows the "Layers" tab,  
Explain what each number refers to: 

1. .............................. 

2. .............................. 

3. .............................. 

4. .............................. 

5. .............................. 

6. .............................. 

7. .............................. 

Second question: Order steps to export file with appropriate extension: 

( ) From the File menu choose Export, select the appropriate extension of the 

file and the file name. 

( ) to merge all layers into a single layer, choose Flatten Image from the Image 

menu.  

( ) ensure that all layers are Visible. 

Exercises  

 

 

 1 2 

3 4 

5 

6 7 
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Prepare this Question for the next lesson: 

Filters are used for the modification and changing the 

appearance of the image. 

What is the Filters?     And how it can be used? 
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Lesson Six 

Edit an image using Filters 
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Objectives 

By the end of this lesson, the students will be able to: 

 identify the concept of Filters. 

 identify how to use Filters. 

 change the appearance of an image using Filters. 
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A Filter is used to help change the apearance of 

an image. 

To use a filter , select the suitable filter from 

the Filters menu. 

 

 

 

 

 

 

 

This filter is used to wipe out or darkening the image. 

Get it from         Filters menu → Blur → Blur    

 

 
 

 
 

 

 

 

Original Image      Image after using Blur filter 

 

Change the appearance of an image using Filters 

 

1- Blur 
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Emboss is used as following: 

Filters menu → Distorts → Emboss. 

 

 
 

 

 

 

 

 

 

Original image    Image after using Emboss 

 

 

With the help of your teacher, open this image from image folder, apply Emboss 

 

 

 

 

 

 

 

Original image     after applying Emboss 

 

2- Emboss (enrichment) 

Activity 
(1) 
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It can be used as following: Filters → Distorts → Page Curl. 

 

 

 

 

  

 

 Original image     image after using Page Curl 

 

 

With the help of your teacher, open this image file from image folder and apply 

Page Curl filter 

 

original image        after using page curl       a curl layer is added  

Notice: When we apply Page Curl, a new layer is added “Curl layer”.  

Discuss this with your teacher 

 

  

3- Page Curl (enrichment) 

Activity 
(2) 
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Supernova is used as following: Filters menu → Light and Shadow → Supernova. 
 

 

Original image          after using Supernova filter 

 

 

To reach the appearance as in the image here 

after using the filter, you must modify the 

properties as in the picture on the right. 

  

 

 

 

 

 

 

 

4- Supernova (enrichment) 
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With the help of the teacher, open the image from the pictures folder, use 

Supernova. 

 

 

 

 

 

 

 

Original image    Image after using Supernova 

 

 

 

 

Use Film filter as following: Filters menu → Combine → Film. 
 

 

Original image      Image after using Film 

Activity (3) 

 
 
 

5- Film (enrichment)  
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To reach the appearance as follows, you have to modify the properties of the 

effect as in the dialog box. 

  

 

 

 

 

 

 

 

 

 

 

 

 

Use the filter Weave as follows: Filters menu → Artistic → Weave 
 

 

Original image      Image after Weave 

 

 

Image file 

name 

6- Weave (enrichment) 
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With the help of your teacher,  

open the image from the images folder and use Weave filter 

  

 

 

 

 

Original image      Image after using Weave 

Notice: 

When using Wave filter, a new layer called Pasted Layer is added. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

                             Filter layer after hide the image layer.  

Activity (4) 

 
 
 

Filter 

Layer 

After hide 

image layer 
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This filter is used as follows: Filters menu → Decor → Old Photo 

 

 

 

 

 

 
 

 

original image      image after using the filter 

Notice: in the dialog box of the filter properties, 

when selecting “Work on copy” option, the filter is 

applied to a copy of the image file. 

 

 

 

With the help of your teacher, open the image from the iamge folder and apply  

“ Old Photo” filter. 

 

  

 

 

 

Original image      image after using the filter 

7- Old Photo (enrichment)  

Activity (5) 
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This filter is used as follows: Filters menu → Map → Map Object. 

 

Original image     Image after using the Map object filter 

 

- To reach the image appearance as in the picture, modify the filter properties 

as in the dialog box. 

  

 

 

 

 

 

 

 

 

8-Map Object (enrichment) 
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With the help of your teacher, open the image from the images folder and use 

Map Object filter 

  

 

 

 

 

 

Original Image    image after using the “Map Object “ 

  

 

 

Remember 

The filter is used to help change the appearance of the image. 

When applying the filter, a new layer is added to the image or a 

new file is ceated. 

To use a filter, open the Filters menu and select the apropriate 

filter. 

 

 

 

Activity (6) 
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Question 1: Put () in front of the right sentences and (X) in 

front of the wrong one: 

1. A filter is used to help change the appearance of an image.   (     ) 

2. To use filter, from the “Filters” menu, select the suitable filter. (   ) 

3. When we use ‘Filters”, a new layer is added or a new file is created. (  ) 

 

Question 2 : Complete the following: 

In the dialog box of the “Old photo” properties, 

when select “Work on Copy “, this means 

…………………………………………………………. 

.......................................................... 

 

 

 

 

 

Answer is to be done through MS Word in  the Lesson Six Answer file 

  

Questions 
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Prepare for the next lesson 

Using the tools in image creating and editing program  

How can you design and create a portrait? 
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Lesson Seven 

Image types 
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Objectives 

Specific objectives (procedural): By the end of this lesson, the 

student will be able to: 

 

 •differentiate between bitmap Images Raster and Vector 

Images 

 •recognize the color mode of the image (Image Mode). 

 •modify one of the images Image Mode. 

 •export the image file with an appropriate extension. 
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Image types: 

1-  Raster Images. 

2- Vector Images 

Raster Images: 

It consists of contiguous points (Pixels), and each image contains rows and 

columns of the Pixels and the higher the number of the Pixels, the greater image 

clarity is, It has a large storage area for the image, and the quality and clarity of 

the picture change when zooming in or out. 

 

 

 

 

 

 

Image Raster 

 

 

 تدريب

 
 
 

Image types 

 

Part of the picture when enlarged 

Of contiguous points (Pixels) The original image  
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Vector Images: 

It is characterized by no change in image quality and clarity when enlarged 

or minimized, and it has a small storage area. 
 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

With the help of your teacher, look for the types of images and the difference between 

Raster and Vector Image. 

 

Activity (1)  
 
 

Image Raster 
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There are three modes of color of the image, and you can change the status or 

condition of the color image through the Mode command in the Image menu, 

namely: 

1. RGB mode. 

2. Grayscale mode. 

3. Indexed mode. 

 

 

 

 

 

 

 

 

Through the command RGB in the 

Image menu, the colored image is converted to RGB mode, RGB color mode fits 

very much in the case of displaying images and graphics through the computer 

screen. 

RGB mode consists of the primary colors (red, green and Blue), and these 

three colors are mixed and united with different degrees of mitigation, lighting 

and intensity to give each primary color of these colors 256 color degree. 

Image Mode 

 

1- RGB mode 

 

RGB mode 
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Grayscale mode 

The image can be converted to the color gray case by using the command 

Grayscale from Image list, where Grayscale mode reaches up to 256 degrees of 

gray ranging from black to white. 

An Important note: 

- The image can be converted from RGB mode to Grayscale by selecting 

the command Gray scale from Image menu. 

- But it should be noted that the image will lose its Colorimetric data of 

RGB mode so that the RGB mode for the image cannot be restored 

again. 

 

 

 

Indexed mode: 

You can convert the image to Indexed mode by using a command Indexed 

from Image list. 

 

 

With the help of your teacher search for: RGB mode – Grayscale mode – 

Indexed mode. 

- More information can be found on the link: 

http://docs.gimp.org/2.8/en/gimp-image-mode.html  

2- Grayscale mode 

 

3- Chromatography Situation of the image 

Indexed mode 

Activity (2) 
 
 

http://docs.gimp.org/2.8/en/gimp-image-mode.html
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With the help of your teacher, try to do the following: 

4- Open an image file in the program. 

5- Change the color mode of the image. 

6- Copy the image from its original file. 

7- Paste the image into a new layer in the other file. 

8- Edit the image layers so that  the original image become as follows: 

 

 
 

 

 

 

 

 

 

 

 

 

 

The original image 

 

 

 

 

 

 

The image after its modification 
 

 

 

 

 

 

Activity (3) 
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Steps to implement the activity 
 

With the help of your teacher, try to do 

the following: 

- Open the image file from the "Images" 

folder.  

 

       RGB mode 

 

- Change the color mode of the image from RGB to Grayscale by selecting 

Grayscale mode from the Image menu. 

 

 

 

Grayscale mode 
 

 

 Reopen the original image file RGB again so that two files appear on the top 

of the window as shown in the figure. 

 

 

 

 
 

 

 

-  

 

 

The first image file 

after converting to 

Grayscale 

RGB color image 

file after reopen 
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- Copy the gray Grayscale image file by selecting all from the Select menu. 

- Go to RGB color image file by click its tab on the top of the image window. 

 

 

-  Paste the image Grayscale in the colored image file RGB through: 

      Edit menu                         Paste as                 New Layer 

-  Grayscale image appears after the paste in a new layer on top layer RGB color 

image. 

 

 

 

 

 

 

 

 

 

 

- Use one of the selection tools such as Fuzzy Tool 

to determine part of the gray image. 

 
 

 

 

 

 

 

 

 

Colored image RGB after 

activation 
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-To delete the part that was selected, click on the Edit menu and choose Cut. 

- After deleting the selected part in the upper layer, part of the content of the RGB 

colored bottom layer appears. 

 

 

- to remove the selection, choose None from 

the Select menu. 

 

 

 

 

 

 

 

 
The image after modifications     
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After completing the work on the image, image saving stage comes. 

The Save command is selected from the File menu where GIMP program gives 

extension to the image file .XCF, where all information about the image (its layers, 

transparency …) is kept. This extension is useful in the case of re-opening the 

image file and editing it. But it should be noted that this extension is not suitable 

for reading through a variety of images programs. 

Export image file using the Export command from the File menu: 

In order for other programs to be able to read the image file, the image must 

be exported through the Export command from the File menu where the 

appropriate image file extension such as (JPEG -GIF - PNG ...) is selected. 

 

 

 

 

  

Export image file 
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Remember  

Image types: 

- Raster Images. 

-Vector Images 

There are three modes of color of the image; namely: 

1. RGB mode. 

2. Grayscale mode. 

3. Indexed mode. 

 

RGB mode consists of the primary colors (red, green and Blue), and these three 

colors are mixed and united with different degrees of mitigation, lighting and 

intensity to give each primary color of these colors 256 color degree. 

 

Grayscale mode 

The image can be converted to the color grayscale by using the command 

Grayscale from Image menu, where Grayscale mode reaches up to 256 degrees 

of gray ranging from black to white. 

-The image can be converted from RGB mode to Grayscale by selecting the 

Grayscale command from Image menu, But it should be noted that the image 

will lose its Colorimetric data of the RGB mode so that the RGB mode for the 

image cannot be restored again. 

In order for other programs to be able to read the image file, the image 

must be exported through the command Export from the File menu where the 

appropriate image file extension such as (JPEG -GIF - PNG ...) is selected. 
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Tick (√) in front of the right answer and (×) in front of the wrong one: 

 

 

1. In the Vector Image, the quality and clarity of the picture change when zooming in 

or out.          ( ) 

2. Copy Raster Image is characterized by a change in image quality and clarity when 

enlarged or minimized.        ( ) 

3. There is only one color mode of the image    ( ) 

4. RGB mode fits very much in the case of display images and graphics through the 

computer screen        ( ) 

5. RGB mode consists of the primary colors (red, green and black) ( ) 

6. You can convert the image to the color grayscale using the Grayscale command. (  )  

7. You can convert the image from RGB mode to Grayscale mode where the image 

loses its Colorimetric data       ( ) 

8. In order for other software to read the image file, the image must be exported 

through the Save command from the File menu    ( ) 

9. The image Can be converted from RGB mode to Grayscale mode ( ) 

10. The large size storage area is from the Vector Image defects ( ) 

 

 

 

 

 

 

Exercises 
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A warm up Question for the next lesson: 

After knowing and using some of the tools and the image 

creation and processing program, how can you design and 

create a painting? 


